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GETTING STARTED 
 

Lumen Cloud Communications (LCC) provides a VoIP service subscription to make 
audio or video calls with the LCC desktop or mobile client. Please contact Lumen to 
order and activate your Lumen Cloud Communications service to use this application.  

System Requirements 
Operating Systems Windows 10 

macOS 10.13 (High Sierra) 
macOS 10.14 (Mojave) 
macOS 10.15 (Catalina) 
macOS 11.2 (Big Sur) 

Processor Minimum: Core 2 Duo 2.1 GHz 
Recommended: i5/i7 2.4 GHz and above 

Memory Minimum: 4GB RAM 
Recommended: 8GB RAM and above 

Hard Disk Space 400 MB (Install/Upgrade, 200 MB operation) 

Connection IP network connection (broadband, LAN, wireless) 
Constant internet connection 

Audio Device Full-duplex, 16-bit, or use a USB headset 
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Install and Sign In 
A Welcome email that contains your login details was sent to you when your account 
was created. Click the link in that email to create your password, then download the 
app at https://www.lumen.com/help/en-us/cloud-communications.html and sign in.  

Check Remember sign in information and Sign in automatically to retain login 
information and activate the client more quickly.   

 

Can’t sign in?  
• If you can’t remember your password, click Forgot your password? and check 

your email for a link to reset it. If you don’t receive that email, please contact 
Customer Support.  

• You can be signed in to the LCC app on up to two devices, such as your 
computer and mobile phone. To deactivate an old device so you can sign in on a 
new one, see Devices for more information. 

 
USING LUMEN CLOUD COMMUNICATIONS 
 

The screenshots in this guide are from the Windows app. The Mac interface is 
essentially the same, but the menu is at the top of the screen and includes LCC, 

EXIT LCC 

We recommend keeping LCC open in the background, but if you need to sign out, go to Softphone 
(Windows) or LCC (Mac) > Sign Out.   

https://www.lumen.com/help/en-us/cloud-communications.html
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View, Windows, Contacts, and Help. 

 
 

COMPACT VIEW 

 
To create the compact view, hide all resources on 
the View menu. 

DETACHING TABS (WINDOWS) 

 
The Contacts, Favorites, History, and the Directory 
tabs can all be detached from the on-screen 
phone into their own window.  
Go to the tab you want to detach and then click 

. To reattach the window, click . 
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Making Calls 
Use LCC client to place and receive audio and video calls, as well as host conference 
calls. LCC has default actions for the call button and for double-clicking a contact. 
Update these defaults in Softphone > Preferences > Application.   

Using the dial pad to make a call 
Type the name, phone number, or email of the person you want to call in the Enter 
name or number field. Press Enter or Tab to dial. 

 

Auto-Complete 
As you type, LCC may display suggestions for 
completing the entry. Use your mouse or the up and 
down arrow keys on your keyboard to move through the 
list of suggestions.  

 

More Menu 
To make a video call or start a conference, click the 
More menu arrow on the right after typing the person’s 
full name, phone number, or email. 

 

Redial 
To redial the last-dialed contact, click  Make a call. 
To redial a recent contact, click the arrow in the Enter 
name or number field and select a contact. 

 

 

Using Contacts, Favorites, History, or Messages 
In the Contacts, Favorites, or History tabs, scroll through your contact lists or type a 
name, phone number, or email address in the search bar to find the contact you want 
to call.  
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Click-to-call 
Hover over the contact you want to call to reveal the 
click-to-call button and click  Call this contact. 

 

Shortcut Menu 
Right-click (Windows) or CTRL+click (Mac) on the 
contact you want to call, then click Call or Video Call. 

 

FEATURES 
 

Call Transfer 
In an unattended or blind transfer, you transfer the call to the target without talking to 
the target first. An attended transfer occurs when you talk to the target before 
transferring the call. 

1. While you have a call established, use any of the methods for placing an audio 
or video call to place a second call. LCC client puts the first call on hold and 
dials the second call. 

2. Click  Transfer at the bottom of the call panel. The call is placed on hold.  
3. Type the name or number of the second party, use the redial drop-down list, or 

drag the target’s contact number into the Enter name or number field.  

Unattended transfer 

1. Click Transfer Now if it’s your default action or click the drop-down arrow next to 
Call First and select Transfer Now. 

2. LCC client attempts to transfer the call to the target. The call may end 
immediately or show Transfer: Calling. Don’t hang up yet—If the target doesn’t 
answer, the call will return to you. 
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Attended transfer 
1. Click Call First if it’s your default action or click the drop-down arrow next to 

Transfer Now and click Call First. 
2. When the call is answered, speak to the target. If they want to take the call, click 

Transfer Now. If they don’t want the call, click X at the bottom of the call panel.  
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Contacts 
LCC contacts are pre-populated and managed by your system administrator. Other 
contacts can be added by you.  

View contacts 
Go to the Contacts or Favorites tabs to view your contacts. Use the search bar to 
locate an individual contact or scroll to the list. 

CONTACT INFO FLYOUT 

 
Click on the name of a Contact or Favorite to 
view their contact details.  
For more information, click Profile. 

SHORTCUT MENU 

 
Right-click (Windows) or CTRL+click (Mac) on a 
Contact or Favorite to view the shortcut menu. 
Here you can initiate a call, send a message or 
email, add to favorites, and more. 

Add contacts 

• CONTACTS. In the Contacts tab, click  to add a person to your contact list. 
In the Contact Profile, choose the group of contacts this person will belong to, 
and enter their name and number.  

• HISTORY. From the History tab, select an entry for an unknown contact and click 
 to add them to your contact list. Alternatively, right-click (Windows) or 

CTRL+click (Mac) and select Add to Contacts. 
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• MENU. Contacts can also be added from the Contacts menu (top). 

IMPORT/EXPORT 

Go to the Contacts menu and select Import Contacts or Export Contacts. Contacts can 
be imported or exported in a .csv, .vcf, or Outlook/Exchange Server format.  

Presence 
LCC allows you to share your online status (presence) with team members. When 
LCC is launched, your online status is Available. If you do not use your device for a 
specified period of time (set in Preferences), LCC updates your status to Idle. 

 

• To change your status, click the drop-down arrow and 
select Busy, Away, Not available for calls, Do not disturb, 
or Appear offline. 

• When you make or receive a call and your status was 
Available, LCC updates your status to On the phone. 

• To set a custom status, click on the wording in the status 
indicator and type your status. Press Enter to save. 

 

Screen Share 
Screen share  lets you share your screen 
with anyone who has a browser on their 
device. Screen share sessions do not contain 
audio, so you’ll need an audio call as well as 
the screen share for a complete experience. 
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Voice Mail 
Voice mail is offered through your VoIP service 
provider or through your enterprise’s IP PBX; it 
is not part of LCC. When you have a new 
message, an icon showing the number of 
messages is displayed on the  icon. 
To access your voice messages, click the  
icon or dial the Voicemail Management star 
code.  
 

 

COLLABORATION 
 

Collaboration, also known as Virtual Meeting Rooms, combines audio, HD video, 
screen sharing, messaging, and presence in one virtual meeting. Anyone can join your 
collaboration conference using desktop and mobile devices.  

Host a Conference 
The host is responsible for inviting people to a conference as well as starting a 
conference. Make sure to use a desktop device if you want to share your screen. 

CONFERENCE PIN (OPTIONAL) 

You can set a participant PIN so only those with your PIN can access the conference.  
1. Go to Softphone > Preferences (Windows) or LCC > Preferences (Mac). 
2. Choose the Conferences panel.  
3. Enable Require PIN/Passcode and enter a number. 
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Create a conference  
1. To begin a conference without an established call, type a name or phone number 

in the Enter name or number field, then click the More menu arrow on the right 
and select Start Conference Call. LCC connects to the first participant. 

2. Type a name or phone number into the Enter name or number field and click 
Add. LCC starts a three-party conference call.  

3. To add more participants, click  More options and select Invite to Conference 
Call. 

4. Enter a contact into the Enter name or number field at the bottom of the call 
panel and click Add.  

5. Repeat steps 3 and 4 until you have added all participants to the conference. 
 

 

 

Add participants to a call 

1. Type the first participant’s name or phone number in the Enter name or number 
field, then click the  More menu on the right and select Start Conference Call. 

2. To add another participant, type their name or phone number into the Enter name 
or number field and click Add. 

3. Click  More options and select Invite to Conference Call. Enter a contact into 
the Enter name or number field and click Add. Repeat to add additional 
participants. 

Alternatively, go to the Contacts, Favorites, or History tab. On a contact or entry, right-
click (Windows) or CTRL+click (Mac) and select Add to Call. 

https://docs.counterpath.com/docs/DeskUG/Resources/Images/UG/DeskRetail/calls/briaDeskConfInviteDD2_Win.png
https://docs.counterpath.com/docs/DeskUG/Resources/Images/UG/DeskStretto/calls/confAddButt_Win.png
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Schedule a conference 
1. Click the  Conference icon and select Schedule a Conference. 
2. Your primary calendar application will open. Add invitees and set a time. If set, 

the PIN will be included in the invite. 
3. Send the invitation. 

Alternatively, click Copy Conference Link to Clipboard and send the link another way. 

Start a conference now 
1. Click the  Conference icon and select Start a Conference Now. 
2. On the left side of the conference window, select  Participants. Click , then 

enter the name or number of the next participant. Repeat for additional 
participants.  

3. In the conference window, click  to share your screen. A yellow bounding box 
outlines your screen as a visual cue to what is being shared.  
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Join a Conference 
Participants can join a conference using the LCC client, a web browser, or by dialing 
in. Depending on the host’s settings, participants may enter the conference immediately 
or must wait until the host joins. LCC needs access to your microphone and camera 
for a conference.  

1. To join a conference, click the link in the invitation email or copy/paste it into your 
browser. 
- If the browser detects your LCC app, LCC will launch. 
- If the browser detects that you do not have a LCC client, you can install the 

app, dial in, or join from your browser.  
2. Enter your name and a PIN, if required. Tap Join. The name you enter will be 

displayed to other participants during the conference.  
3. If prompted, allow LCC to access your microphone and camera. 
4. If prompted, enter the conference PIN given by the host.  
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Conference Panel 

 

Video 
To include video in a conference call, click the  Start Video icon. The video that 
the host sees is automatically sent to all participants. If the host pauses or stops the 
video, other participants no longer receive video.  

Participants can choose whether to share their own video. Those that do will have 
(Video) displayed next to their name. 

Separate calls 
During a conference call, you can speak to one of the participants separately while 
maintaining the conference call. Tap  Separate Calls next to the participant, and the 
conference is split into two calls. When you’re done, you can merge the two calls 
back into the conference or end the one-on-one call and return to the conference. 
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Remove participant 
To remove a participant from the conference, select the participant and tap X next to 
their name. 

Instant message 
To send an individual instant message to a conference participant, tap  Send 
Instant Message beside their name. Type in your message and tap Enter.  



Desktop App User Guide Mobile App User Guide 

 

19     

Services not available everywhere. Business customers only. Lumen may change, cancel or substitute products and services, or vary them by service area at 

its sole discretion without notice. ©2021 Lumen Technologies. All Rights Reserved. 

 

 

MESSAGING 
 

Instant messages (IMs) can be sent from the Messages window, the Contacts tab, the 
Favorites tab, or from an active call. 

There are multiple ways to view the Messages window:  

• Click the  Messages icon in the top right of your softphone. 
• Go to View > Messages (Windows) or Window > Show Messages (Mac). 
• Type the shortcut SHIFT+CTRL+M (Windows) or SHIFT+COMMAND+M (Mac). 

 

 

  

PREFERENCES 

Set the action for clicking Enter while typing a message in Preferences > Application. 
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Send a Message 

New conversation 
1. In the Messages window, click  New Conversation.  
2. Search for the person to add to the chat and select them from the list of 

suggestions. Press ENTER to select the first suggestion in the list.  
3. Click on their name below Send A Message to open a chat.  
4. Compose your message, then click  Send Message. 

Existing conversation 
1. Do one of the following:  

- In the Messages window, scroll through your conversations or search for the 
person you want to send a message to, then click on the IM conversation.  

- On the Contacts or Favorites tab, right-click (Windows) or CONTROL+click 
(Mac) on a contact and select Send Instant Message from the shortcut menu. 

- On the Contacts or Favorites tab, hover over the contact and click  Send 
Instant Message. 

- During an active call, go to  More options in the call panel and click Send 
Instant Message. 

2. Compose your message, then click  Send Message. 
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Chat Rooms 
1. In the Messages window, click  New Conversation.  
2. Click Create a Room on the right. 
3. Enter a room name.  
4. Type the name of a person you want to add to the room and select them from 

the list when they appear. Repeat this for all users you want to add to the room.  
5. Click Create.  

In the group chat room, compose your message, then click  Send Message. 

 

Message formatting 
You can use emoticons and formatting in your IM's and chat rooms. The default 
behavior can be modified in Preferences > Application: Messages & Presence. 

FORMATTING WINDOWS MAC 

Bold Ctrl+B Command+B 

Italic Ctrl+I Command+I 

Underline Ctrl+U Command+U 

New Line Shift+Enter CTRL+Enter 

Send Enter Enter 
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CLIENT END USER PORTAL 
 

The Client End User Portal is a web-based service that allows end users to manage 
some of their own services. Go to the  End User Portal tab to access these 
settings.  

Device Logs 
Search through your device logs by filename or full 
text. Sort the results by date, relevance, and size.  
 

 

Devices 
You can log in to LCC on only two devices. If you need to switch to a new device, 
one of your old devices will need to be deactivated first. 
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1. Go to Devices to view your activated 
devices.  

2. Find the record of the device that you 
wish to deactivate, then click Delete. 

3. A message will pop up asking if 
you're sure you want to delete this 
device. Click [Delete] to confirm. 

Now you can log in on another device. 

 

Conferences  
Access your Conference Settings and Conference Records. At the bottom of the menu 
is your personal bridge link. 
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Conference Settings 
Manage your conference settings, including: 

• Your bridge title and description 
• If new participants are automatically 

muted when they join 
• If tones are played when participants 

enter or exit the conference 
• Moderator and participant PINs 
• Grace period after the host leaves 
• Enable automatic conference 

recordings 
• Set up Dropbox for server-based 

recording 
• And more 

 

Conference Records 

View the records of each of your 
conferences, including the start and end 
times, number of participants, and each 
participant’s information.  
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XMPP Photo 

 

Your avatar is the image that will be displayed for your 
contact. Follow these steps to change the photo: 

1. Go to XMPP Photo.  
2. Click Choose File, then locate the image file on your 

computer that you want to use as your avatar.  
3. Click Upload JPEG or PNG Image. 

 

Change Password 

 

1. Go to Change Password.  
2. Enter your old and new passwords. The indicator at 

the bottom will tell you if your password meets the 
following requirements: 
- Your new password must contain at least one 

uppercase letter, one lower case letter, one digit, 
and one punctuation character.  

3. Click Change Password. 

 


